System requirements BIMcollab Nexus

System requirements BIMcollab Nexus

BIMcollab Nexus

The BIMcollab web application runs on any modern web browser which supports TLS 1.2 or a later version. 
The following clients are known to be unable to use TLS 1.2. You cannot use these clients for access to the service.
  1. Android 4.3 and earlier versions
  2. Firefox version 5.0 and earlier versions
  3. Internet Explorer 8-10 on Windows 7 and earlier versions
  4. Internet Explorer 10 on Windows Phone 8
  5. Safari 6.0.4/OS X10.8.4 and earlier versions

BIMcollab Model WebViewer

Supported Browsers

All browsers are supported for the BIM WebViewer, but performance is not equal. Recommended browsers include the following:
  1. Chrome (recommended)
  2. Edge (recommended)
  3. Firefox
  4. Safari
Additionally, 64-bit browsers as well as a minimum internet bandwidth of 40 Mbps will ensure an optimal viewing experience. 
When working with larger models, a 100 Mpbs internet connection (4G) is further recommended. 

Supported Devices

Any device with a stable internet connection is suited for the BIM WebViewer. These include the following:

iOS Version 15+
  1. iPhone - 6S, SE, 7 and above models
  2. iPad - Air 2, Pro, Mini 4 and above models
Android OS Version 11+
  1. Only devices that support Web Sockets and WebGL 2.0
PC/Mac
  1. Minimal requirements are based on browser requirements. However, a dedicated graphics card is highly recommended.
  2. Additionally, 16 GB RAM is recommended for medium size projects, and 32 GB RAM for large scale projects.
When using a mobile device, the speed and performance of the WebViewer depends on the model size. While smaller models are generally viewable, large models require more memory than most mobile phones can provide. This could cause large models to load slowly or even cause the application to crash.
The WebViewer has not been tested in remote desktop setups. Performance and functionality may vary when accessed through a remote environment.

On-premise version

Supported software versions.
  1. Windows 2019 and higher
  2. SQL Server 2019 and higher. Web/Standard/Enterprise versions
  3. IIS Server 10 and higher

BIMcollab Twin

BIMcollab Zoom

BCF Managers



Related article:




    • Related Articles

    • System requirements BCF Managers

      Our BCF Managers run inside your BIM application and therefore have the same system requirements as the BIM tool your are installing the BCF Manager for.
    • Password requirements

      Space accounts for private BIMcollab Nexus spaces require a complex password. This means all passwords need to meet the following requirements: At least 10 characters At least 1 uppercase letter At least 1 lowercase letter At least 1 number At least ...
    • On-premise BIMcollab Nexus FAQ

      We have a limited version of BIMcollab Nexus available for on-premise installation from Ultimate 500+ users (without BIMcollab Model Viewer and without security or feature updates). In our offering we focus on multi- and single tenant solutions based ...
    • Set your language of your BIMcollab account

      My BIMcollab ID Go directly to the My BIMcollab ID page. Select the language you prefer under 'Preferences' Click 'Save' BIMcollab Nexus spaces Every BIMcollab Nexus space, including a trial space, has a default language which is set by the space ...
    • Edit and comment on issues

      In BIMcollab Nexus, as well as with BIMcollab Zoom or the BCF manager you can add comments to existing issues and edit it’s properties, BIMcollab Nexus From BIMcollab Nexus, you can add comments and edit issues from the Issues page and model page of ...