Deprecation of TLS 1.0 and 1.1

Deprecation of TLS 1.0 and 1.1

For security reasons we will be following industry standards by disabling TLS 1.0 and 1.1 starting the 1st of April.
We recommend that all client-server and browser-server combinations use TLS 1.2 (or a later version) in order to maintain connection to BIMcollab services.
You might have to update certain client-server and browser-server combinations.

The following clients are known to be unable to use TLS 1.2. Update these clients to ensure uninterrupted access to the service.
  1. Android 4.3 and earlier versions
  2. Firefox version 5.0 and earlier versions
  3. Internet Explorer 8-10 on Windows 7 and earlier versions
  4. Internet Explorer 10 on Windows Phone 8
  5. Safari 6.0.4/OS X10.8.4 and earlier versions

    On Windows 8 and later versions

    By default, the TLS 1.2 and 1.1 protocols are available if no network devices are configured to reject TLS 1.2 traffic.

    On Windows 7

    TLS 1.1 and 1.2 protocols are not available without the KB 3140245 update.

    Update and configure the .NET Framework to support TLS 1.2

    You'll need to update applications that call Microsoft 365 APIs over TLS 1.0 or TLS 1.1 to use TLS 1.2. .NET 4.5 defaults to TLS 1.1. To update your .NET configuration, see How to enable Transport Layer Security (TLS) 1.2 on clients.


      • Related Articles

      • System requirements BIMcollab

        Cloud version The BIMcollab web application runs on any modern web browser which supports TLS 1.2 or a later version.  The following clients are known to be unable to use TLS 1.2. You cannot use these clients for access to the service. Android 4.3 ...